Fixing unusable network-manager-openconnect-plugin on Xenial Xerus



On Ubuntu 16.04 the network-manager-openconnect and network-manager-openconnect-gnome plugins are not usable because they are to old to use with the current version of network-manager.

This is the english version of this guide from a german ubuntu support forum.

Unofficial built packages are available here:

http://tomtomtom.org/networkmanager-openconnect_1.1.93-1_i386.deb

http://tomtomtom.org/networkmanager-openconnect_1.1.93-1_amd64.deb


NOTE: You won´t get any security updates for this! It is just a workaround until the packages will have been fixed in the official repository!

Using VPN is a security feature - so it is better to build the package manually from source because you don´t know what I put into the packages. :-P


At first remove the unusable packages

sudo apt-get purge network-manager-openconnect network-manager-openconnect-gnome


You will need the build-dependencies.

sudo apt-get build-dep network-manager-openconnect

(NOTE: For this the 'deb-src'-Sources in /etc/apt/sources.list must be active.)

You can do this with sed e.g.

sudo sed -i s/#deb-src/deb-src/g /etc/apt/sources.list


the new dependency for the new version.


sudo apt-get install libnm-dev

and the sourcecode from GNOME project.


wget http://ftp.gnome.org/pub/GNOME/sources/NetworkManager-openconnect/1.1/NetworkManager-openconnect-1.1.93.tar.xz

Unpack the tarball

tar -xf NetworkManager-openconnect-1.1.93.tar.xz

change to the unpacked directory

cd NetworkManager-openconnect-1.1.93

and run the configure script.

./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib/NetworkManager/ --enable-more-warnings=yes --disable-static

start compiling
.
make

and install manually

sudo make install

install the dependency for use the software

sudo apt-get install openconnect


or build a package with checkinstall

sudo checkinstall

If you do so enter this:

networkmanager-openconnect as package name

adduser, libc6, libdbus-glib-1-2, libglib2.0-0, libnm-glib-vpn1, libnm-util2, network-manager, openconnect as requirements

and

network-manager-openconnect, network-manager-openconnect-gnome

as conflicts.

If you get errormessages by installing the package try

sudo apt-get -f install

to resolve unmet dependencies.

To use the software it is necessary to add a systemuser for this

sudo adduser --system --quiet --home /var/lib/NetworkManager --no-create-home --gecos "NetworkManager OpenConnect plugin" --group nm-openconnect}

At last restart the system.